Home Forums Free SciFi Gaming Projects Pioneer Can’t see anything

Viewing 9 posts - 1 through 9 (of 9 total)



Humble Book Bundle ends on 9/11/2019


  • Author
    Posts
  • #58689
    AvatarAnonymous

    Hi,

    I have checked out pioneer and compiled the alpha15 tag. But when I start pioneer, I don’t see any ships or planets. I can see the exhaust of the ship’s engines in the menu screen at the start of the game, but not the ship itself. Once inside the game, I can see the cockpit, but apart from that I only see some floating names. I can see the names in the 3D map screen (F2), but not the stars I suppose must be there. Most confusingly, I can see a ship turning around in the Ship Information screen (F3) perfectly. In the shipyard, I can see all the available ships as well.

    I’m on 64 bit Arch. I’ve followed the instructions on http://pioneerspacesim.net/wiki/index.p … ng_pioneer, including symlinking the data folder into src/.

    What could be going on? Thanks for any help.




    Humble Book Bundle ends on 9/11/2019


    #84258
    Avatardurandal
    Participant

    Broken drivers? I can not guess your machine configuration.

    Disabling HDR and/or Shaders may help.

    #84259
    Avatarrobn
    Participant

    We are vaguely aware of problems with certain drivers and chips, notably the free Radeon drivers and Intel GPUs. If you can, try without shaders. Also if you can, try with an older version of Pioneer – perhaps alpha 12? Let us know the details of your GPU, drivers and how your tests go.

    #84260
    Avatarfluffyfreak
    Participant
    diederick76 wrote:
    I’m on 64 bit Arch.

    When you say this do you mean the 64bit version of Arch linux? Or just a 64bit architecture? I’m guessing the former.

    As the others have said the first thing we need to know is what hardware and software/OS you’re actually running.

    Then we should really be able to start helping 😀

    #84261
    AvatarAnonymous

    Turning off shaders helped. Now can see everything. 😀

    As for my computer, it has a 64 bit CPU (Intel Core i5), and I’m running 64 bit Arch Linux. I have an Intel graphics chip with an Nvidia GPU in a hybrid configuration which under Windows is called Optimus, and which under Linux is mimicked by something called Bumblebee (https://wiki.archlinux.org/index.php/Bu … w_it_works). The reason I thought it didn’t have anything to do with that is that other 3D applications (glxgears, celestia) don’t seem to have a problem.

    Thanks for the help.

    #84262
    Avatarrobn
    Participant
    diederick76 wrote:
    Turning off shaders helped. Now can see everything. 😀

    Ok, that’s something 🙂

    Quote:
    I have an Intel graphics chip with an Nvidia GPU in a hybrid configuration which under Windows is called Optimus, and which under Linux is mimicked by something called Bumblebee (https://wiki.archlinux.org/index.php/Bu … w_it_works). The reason I thought it didn’t have anything to do with that is that other 3D applications (glxgears, celestia) don’t seem to have a problem.

    I’m going to guess then that you’re using Nouveau and not the proprietary Nvidia drivers? If you are using the proprietary driver then I’m going to guess there’s something deeper with all this Optimus/Bumblebee business.

    That said, I’ve fairly confident there’s something a little quirky in our shaders that is causing problems on less mature drivers. We’ve seen shader glitches at various times in the past with open source drivers and under VMware.

    Thanks for the info!

    #84263
    AvatarAnonymous
    robn wrote:

    I’m going to guess then that you’re using Nouveau and not the proprietary Nvidia drivers? If you are using the proprietary driver then I’m going to guess there’s something deeper with all this Optimus/Bumblebee business.

    That said, I’ve fairly confident there’s something a little quirky in our shaders that is causing problems on less mature drivers. We’ve seen shader glitches at various times in the past with open source drivers and under VMware.

    Thanks for the info!

    No, in fact I’m using the nvidia drivers, not the nouveau drivers:

    $ dmesg | grep nvidia

    [ 6.909001] nvidia: module license ‘NVIDIA’ taints kernel.

    [ 7.032248] nvidia 0000:01:00.0: power state changed by ACPI to D0

    [ 7.032255] nvidia 0000:01:00.0: power state changed by ACPI to D0

    [ 7.032260] nvidia 0000:01:00.0: enabling device (0000 -> 0003)

    [ 7.032269] nvidia 0000:01:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16

    [ 7.032279] nvidia 0000:01:00.0: setting latency timer to 64

    If you need more info, I’d be happy to help.

    #84264
    AvatarAnonymous

    Re-reading the Bumblebee page on the Arch wiki, I realised I wasn’t using Bumblebee at all. To use it, I have to do

    Code:
    $ optirun ./src/pioneer

    The difference is nicely illustrated using glxgears:

    Code:
    $ glxgears
    Running synchronized to the vertical refresh. The framerate should be
    approximately the same as the monitor refresh rate.
    294 frames in 5.0 seconds = 58.783 FPS
    $ optirun glxgears
    3759 frames in 5.0 seconds = 751.706 FPS

    When running pioneer, I forgot to use the optirun command, so I was only using the Intel chip. Someone mentioned shader problems with Intel chips, so that will have been it. But when I do run pioneer through the optirun command, I can use shaders without problems 😀

    #84265
    Avatarrobn
    Participant

    Great! Well not great, but at least consistent with what we already know. Thanks for testing, and enjoy Pioneer in its shaderful glory 🙂

Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.