Home Forums Free SciFi Gaming Projects FFED3D Commander Steve’s adventures in the afterlife

Viewing 12 reply threads

This HumbleBundle expires on 12/31/2018

  • Author
    • #61621

      Following on from the admittedly quite confusing thread titled “**New FFED3D builds from Ittiz & AndyJ**” this is where I’m going to highlight issues that have crept up after the intended end of the game (January 3317).
      The issue I have right now is that the same two adverts for journals pop up on the bulletin board no matter where I go, and the others never do. Plus the “**INFORMATION FOR SALE: I have information for sale that may be of interest to friends or colleagues of Jo Merion of Olwain**” post has been stuck there for several game-months now.
      Andy, there’s a save game [here](http://www.frontierastro.co.uk/temp/FFED3D/FFED3DAJ/Mags “frontierastro.co.uk/temp/FFED3D/FFED3DAJ/Mags”) if you fancy having a look at it 😐

      This bundle expires on 12/20/2018

    • #110399

      Cheers Steve, I’ve marked the thread so I’ll notice an update a little more quickly next time :blush:

      Just for the initiated, “the afterlife” is a patch feature in the FFED3DAJ v1.12 beta4 that is being tested, which has extended the players potential lifetime but has turned up “issues” in the years that follow. Well, if you can describe the game completely crashing as an “issue”… as that’s sometimes what happens!
      Anyway this thread will be a discussion of what oddities arise and hopefully (no promises) resolutions will be found to keep Commanders flying well past their bus-pass years!

      Commander Steve has already found that the game crashes around a year later than the standard “use by date”, around the start of 3318, and these were the relevant posts:
      – – –
      “Andy, could you have another look at the fix which prevents the commander from dying in January 3317? I have a save game at Eta Cassiopeia dated 15-Jan 3318 and when I try to hyperspace anywhere, Crashy McCrashface appears. If I use Buffet to advance the in-game date by around 7 days or more, the game is fine. Any less than that and… crash :'(
      It may be an unrelated bug, of course. Depends on how your fix avoids the game’s built-in quietus.”
      – – –
      “If that patch is enabled then it just checks for a different number of elapsed days.

      You suggested the change by PM over on the Frontier forums (11/11/2015) as an assembly change attributed to John Jordan to give an extra 100 years. I just wrapped this with a check to use it or not and used a larger value that the Anisotropic mod uses in “Frontierman” mode (start position 4) instead. (0x13e13e for 1000 vs 0x130b22 for 100 years)

      I presume you probably got it from the Elite newsgroup at some point? It’s discussed with JJ here: https://groups.google.com/forum/#!topic/alt.fan.elite/jSSJVUzmh2w
      Perhaps you could copy a jjffe/glffe .exe, patched it and see if the same happens with the save game?
      By all means email the save game to me too and I’ll see if I can spot where it’s crashing.

      I know that the extended game time in the Anisotropic mod (playing from 3500) switched off the journals & hand-coded missions. I wonder if perhaps there was a reason for this…
      If you increment the time a week & are able to hyperspace – does that actually solve the problem I wonder, or if you time accelerate for a month will it crash again?

      *** Edit ***
      Actually if I stay docked at the start station and use BUFFET to set your date and then accelerate a day it also hangs.
      I’ve just hex edited a JJFFE .exe with JJ’s values and it does the same. Perhaps it is BBS missions/news related…”
      – – –
      ” … looking like the game is crashing when executing the main “event” related to missions in the later years after the commander should have died. This gets called several times after a load and on a new day, and with a variable input parameter. Not all input values cause a crash. It’s a pretty complicated function that triggers other events, does calculations using the number of elapsed days since the start of the game (which seems to be exceeding max integer size in one case) and I’m not entirely sure yet what the purpose of the event function is… possibly it’s generating new missions”…(edited:-)…”as it is generating system information, or perhaps that is something to do with AI for their mission destinations.”

      “That said, I’ve tried disabling this event completely, and have then played out the first assassination mission in your 3319 save Steve, and it still seemed to play out with the target ship arriving in system, departing to the destination – getting shot down – and a successful mission paid upon returning to the issuing system.
      It looks like It’ll take a bit of time & effort to figure out this function & I’ve been full of cold & lacking sleep all week so no ETA on when my brain will take it in! If the number of elapsed days are a problem though, getting too large, I’m not sure that’ll have a solution other than turning the event off. Anisotropic turned this and several other mission-related events off in 3500, so perhaps it’s not vital – there’s a separate piece of code in that mod which I’ve also not figured out yet that “turns off hand coded missions” but again, I’m not sure what effect it has… do the hitchhiker and dreamware missions also potentially repeat with the stories I wonder?”
      – – –
      “Steve – I’ve uploaded a beta 4 [here](https://www.dropbox.com/sh/z1m3gwj2hsb93va/AAB3NT-jbopMnj_xjOeSVL3sa?dl=0).
      This should work with your earlier 3319 save game. I’ve completed one assassination and returned to Fomault to claim the reward, advanced time to get new journals & eventually upset the passenger who left complaining loudly.

      The mission board there also had an entry for the Federal Military. Opening it triggered the other piece of code that I noted the Anisotropic mod disables in “FrontierMan” mode (3500).
      Turns out this generates the “CLASSIFIED” high risk missions such as photographing planetary bases (protected by a defense satellite) so I’ve left the code enabled.
      I’ll be interested to hear though if they still play out OK given the disabled mission event.
      And if you can keep a few saves for test cases (before accepting mission, approaching satellite, base etc as you play through each step to conclusion, that’d be helpful in case of any issues)”
      – – –
      “Testing of beta 4 had been going really well, with no issues apparant until….
      Ok, maybe not so dramatic, but I happened to notice that the bulletin board only gives me subscription offers for RIG and Universal Scientist. No matter where I go it won’t offer the Federal Times, Imperial Herald or Frontier News, irrespective of whether I go to an Alliance, Federation, Imperial or Independent system.
      Curiously, if I load in an old save game the subscription ads for all the journals are there, but not with my current Commander.
      Other than that, all good :)”
      – – –
      “As well as being offered subscriptions to Universal Scientist and RIG everywhere I go, the bulletin board message which reads “INFORMATION FOR SALE: I have information for sale that may be of interest to friends or colleagues of Jo Merion of Olwain” popped up a few game-months ago and appears everywhere, all the time. Not sure if this is normal game behaviour, but I suspect not :/”
      – – –
      Right, so that’s the situation up to date… moving forward…

    • #110400

      Right so actually I missed the earlier comment that “Curiously, if I load in an old save game the subscription ads for all the journals are there, but not with my current Commander.” – do you still have that save Steve, was that just before the crashes started to happen in 3319 and perhaps the current beta stops some journal subscriptions from appearing?

    • #110401

      Ah left it too long to edit (need to get this changed!)

      Steve – I notice that in your saved game linked in the OP (2-Apr-3321) that the two journals that keep appearing have 2082 issues appearing, where as the others only 1482 issues – perhaps they’ve blown some value internally. Do you often buy new subscriptions when you see them? I have an older save of yours (4-Jun-3294) where you have a mere 994 issues (82 years!) left to read. Perhaps there’s no check on oversubscribing and you’ve hit values that register as running out on those two?

    • #110403

      Yes, I did go a bit crazy on the subscriptions! πŸ˜€

      I think you’re on to something there Andy, and unfortunately it looks like extending the commander’s life beyond January 3317 causes a number of issues with the game. Even using Buffet to advance a few years can cause problems with the journals πŸ™
      Here’s what I tried…

      I went back to the Gateway start position at 1-Jan 3250 and equipped my ship/commander with how things are in my latest save game. At that point you have 11 subscriptions to each of the journals. You can buy subscriptions to Frontier News, Universal Scientist and RIG at Old Blackelk. When I used Buffet to jump to 2-Apr-3321 I found I had 153390771 subscriptions left! Advancing to the next monthly update reset them all to “No subscription” and they were all blank.

      I bought a subscription to one of the journals and jumped to the next update. The story picked up at a point I assume the program found was appropriate. Frontier News, Universal Scientist and RIG were still the only journals available and this was the case wherever I went.

      I started again in 3250, bought 10-year subscriptions and jumped forwards 5 years. Those publications for which I hadn’t bought extra subscriptions ie. they’d run out gave silly values until the next update when they zeroed. Those which I still had valid subscriptions to updated but only by one month. For example, the Frontier News referred to “last month’s Wiccan Ware race” which actually takes place in Jan/Feb 3250. By flying around I was able to buy subscriptions to all the journals.

      In relation to your point about the two journals that always appear having more issues left in my subscription, they only way I can think of to “zero” them is to advance a crazy number of years and update. When I did this they reset ok but those two journals were still the only ones that were offered anywhere, and that blasted “Jo Merion” ad stil popped up everywhere too!

      In conclusion, it seems using Buffet to advance time can mess up the journals to some degree, but going beyond 3317 renders some publications permanently unavailable.

      I’ve decided to go back to 1-Jan 3250 (by re-starting the game, not using Buffet!) with everything else the same. Might even try out some of the scripted missions! Should be a lot easier now, in my super-Viper B)

      I will undertake further investigations but for the mean time hope this helps, Andy…

    • #110406

      Well the “Merion” and other hand coded missions are easy to knock out, but they all go together unfortunately. I can add a .cfg option for that. (well, I have done as it was easier to test!)

      So unfortunately (or not) this also removes the newspaper subscription offers, the “Doom is coming” type posts and the “Join the Federal/Imperial Military” posts.
      I’m not sure that any of them are actually useful, I’m not sure what the military entries actually do, so perhaps I could just switch them all off after the normal “date of death” and worry no more about them? (it’d be a default that could be undone anyway)

      I’ve been digging in the last couple of evenings, but unfortunately, I’m still not sure how these actually end up in the active missions list.
      The normal missions are created by obvious functions (blocks of program code) that reference the various text strings in a way that doesn’t need too much leg-work to figure out their purpose. The hand-coded missions unfortunately seem to be copied from static data -which I now know lives in with the bitmaps in the jjffe files! – but this is much less straight forward. I’ve spotted the default wiccan wares mission and identified 2 places that could be the reference to the mission description – so potentially I’d be able to work through the other data entries and identify the rest of the missions – but it’ll be a fair deal of work… ain’t going to happen anytime soon, but it might eventually help catch those missions such as the hitch-hikers mission which sometimes fails to complete, and then I could perhaps try and figure out why. A lot if if’s, but’s and maybe’s though.
      I’ve also found a group of functions that get triggered when starting the game and also when opening a hand-coded missions, perhaps other nearby functions serve a purpose in adding them into the list. :sweat:

      Anyway, if you are happy to play as “Son of Steve” now, then I guess I’ll park it for the time being and look towards tying up 1.12. Other than the adverts following you about – the game is stable now in these extended years? That’s good if so, as I didn’t have to turn too much off!
      (I do have a few settings in reserve now that’ll disable other ‘events’ if need be, and it won’t need a new build)

      Took a look at the subscription number too. It looks like it must be holding a number of days for the subscription, as it decreases the value by the number of game days (and divides by something – I’ve not debugged to see what) before displaying the subscription value.
      It would be easy to limit the subscription value on the journals screen, e.g. to 9999 to avoid any large number without affecting anything.
      I don’t know why it would get such a huge value as we’ve seen – It could be that BUFFET isn’t setting something when jumping forward in time that then affects the subscription. But again because the “buy subscription” screen is actually a hand-coded mission, I’ve no idea yet what actually updates the values, or with what, or why some are constantly available but not the others!

      – Actually just re-reading your last post about skipping forward from 3250 – perhaps the ‘new day’ event in the game increments or decrements something in the journal subscriptions data (yeah it’s a woolly blob of data) and so jumping forward loses however many days increments would have been applied.
      If that’s the case, well then as I said earlier, I don’t think I really want to try to chase and correct BUFFET created issues – even if I could spot them (and right now, the journals/hand-coded missions are a mystery anyway)

      If you do want to continue into the twilight years, then please do post any observations. I’ll probably upload a beta 5 tomorrow when I’ve removed some debugging stuff so that you can try switching off the hand-coded missions and see if they matter or not.

      Otherwise… chapter 2… Son of Steve. Perhaps I could encourage you to keep a set of HC-Mission related saves? e.g. before accepting. just before doing whatever to complete it (e.g. blowing something up) and just before docking if that will register the mission completion. Honestly I will replay it myself at some point lol πŸ˜‰

    • #110437

      OK, I’m working through the game and compiling a set of hand-coded mission saves, as you mention above. I’m not using Buffet to advance the game time, as I’m not sure what side-effects it might have. The process is therefore taking a little bit of time, not helped by Real Lifeβ„’ getting in the way recently. I’m making good progress though πŸ™‚

    • #110438

      We’ve been playing it since the mid 90’s, there’s no rush is there πŸ˜‰

    • #110442

      Hi Andy, i’ve just got around to trying beta4, and after carefully copying across my settings into the new config, i’ve run into a display problem that didn’t arise previously…

      It’s not an uncommon issue – ED does it also – but i’m running in a window that spans two monitors. Previously in 1.11 this worked fine. However in beta 4 it appears the maximum window size it can open in is limited by the actual full-screen size limit of either individual monitor.

      Specifically, i’m using two Triplehead2Go’s, each with 3840 * 1024, so i’m setting my windowed size in the .cfg to 3840 * 2048 – which wasn’t an issue in 1.11 – but now the max window size it will open in is 3840 * 1024. If i then resize the resulting window by doubling the horizontal scanlines (via WindowsBorderlessGaming or SimpleRuntimeWindowEditor etc.), the proportion’s corrected but half the scanlines are missing, so it’s all jaggedy and aliased..

      I’ve also tried dropping down to my minimum double-triplehead resolution, 1920 * 960, with the same result – it ignores that setting and opens in a max window size of 1920 * 480. Again, i can then stretch that window vertically, but this just stretches the horizontal scanlines without actually doubling the resolution.

      Not sure what changes under the hood might’ve caused this, and it’s admittedly peculiar to my setup (there’s probably only a handful of double-triplehead gamers in the world, and i’m doubtless the only one playing FFED3D), but 1.11 opens at whatever windowed resolution i put in the config..

      Don’t sweat it, i’m more than happy sticking with 1.11 for now… just a heads-up..

      Thanks again for your amazing work of course!

    • #110448

      Right, gonna spend some time getting those save games ready this weekend. I had some computer problems in the week, specifically everything overheating and the machine shutting down. I took the heat sink off the CPU and cleaned all the dust out, cleaned the fan as well and put it all back together with a nice new splodge of thermal paste. SpeedFan now reports that the computer is cooler than a polar bear wearing sunglasses B)

    • #110450

      Hi MrVibrating,

      I suspect that you might still have “enableBorderless=1” and “defaultBorderless=1” defined in the [VIDEO] section of your new .cfg file, or perhaps there’s no entries for them if you’ve created an empty one with just your own preferences in it?
      The default behaviour is on (=1) and this will cause FFED3DAJ to create and launch in a borderless view itself – to keep things simple for new players it automatically sizes to fit the the primary screen.
      I’m guessing that you normally want to run it starting in Windowed mode instead and then use an external application to switch to borderless mode, so make sure to specify both “enableBorderless=0” and “defaultBorderless=0”.
      I took a look at the code around this anyway just to make sure I hadn’t changed anything – and figured I could quickly add a couple of extra settings for windowed & borderless modes to improve things. The next build will let the user turn off the automatic size/position of borderless mode and define it for themselves – so that should let you span both monitors without needing the help of an external application, and it’ll allow the user to fill their preferred monitor.
      Windowed mode also has x/y offsets so that the user can define where that will initially open too.
      (And if you use the built-in borderless mode, you’ll still be able to toggle between it and perhaps a smaller window if you needed to)

      Anyway I’ll see where the brain-cell count is at tomorrow and perhaps scrape together a beta 5 – still need to tidy up the extra-life settings/asm hooks that I’d meant to look at the other week first of all though :blush:

      Once your up and running with it on both monitors again, you do realise you’ll have to show us what that looks like!
      Feel free to create a new thread about multi-screen/borderless etc if you want to!



    • #110451

      Hi Steve!
      Sorry x-posted there, had the page open for a fair while and didn’t spot an update.
      So you haven’t played through all the game missions already have you? No wonder that PC’s running hot if you have πŸ˜†

    • #110506

      Hi Andy, hope things are well with you, and the default window position settings options sounds like a perfect solution…

      I had another play with beta 4 tonight, just in case i had indeed forgotten to set the borderless toggles in the .cfg… and no, i hadn’t… but upon your suggestion i then tried enabling the borderless toggles in the 1.11 .cfg… and this perfectly replicated the issue i’m having with 1.12beta4!

      In other words, it appears that 1.12b4 is assuming that borderless is toggled on, even though it’s set to off in the .cfg!

      Still, no biggie, more than content with 1.11 for now… i do look forward to trying out the new joystick functionality at some point though!

      Thanks again,


Viewing 12 reply threads
  • You must be logged in to reply to this topic.