Home Forums Free SciFi Gaming Projects Pioneer Hi from me, and a bug

Viewing 9 posts - 1 through 9 (of 9 total)



A lot of scifi games are for sale on Humble Bundle, deals end on 8/19/2019


  • Author
    Posts
  • #58620
    Avatarmatthewfarmery
    Participant

    Hi new here, but been lurking for a while, but I decided to register to say hi and Im a old time elite / frontier fan, played both on the amiga a long time ago, (still got the game disks and the amiga somewhere 😎 )

    but this game really does rock, on high detail this game looks amazing,

    anyway, another reason I decided to post, I run into a bit of a brick wall, I have a save on frye station, (using the adder) now the thing is, if I hyperspace to Epsilon Eridani, I get a error message about trade ships, with the same save, it can do the same error if I buy anything, but if I leave the station then hyperspace its usually, but not always fine, Im using one of the night builds, pioneer-1fee3ed-win32

    while the same error is the same as

    https://github.com/pioneerspacesim/pioneer/issues/513

    I see the issue has been closed, so has the issue finally been fixed? as its a bit of an annoying issue, strange thing mind, I never had this problem up to now, so not sure if its because of that bug, or something else is up? I have included my save if anyone wants to take a look

    its pretty much repeatable, I did play around with alpha 14 and encountered this bug a lot, but far less so in this nightly build

    the other thing I noticed, you can pickup missions that are too old, that is if you are on day September 14, and you can still see missions that have a deadline of 12 of September, so out of date missions need to be removed

    but apart from that, this is a great game, I’ve had a lot of fun in this game, I been following it for a while, and yes its certainly getting better with each build and update

    if this is alpha, can’t wait until it hits beta then RC then final, really is a beautiful game

    I congrat the devs for a job well done and keep up the great work you are doing,




    A lot of scifi games are for sale on Humble Bundle, deals end on 8/19/2019


    #83685
    AvatarBrianetta
    Participant

    I’ve re-re-opened the issue.

    #83686
    Avatarmatthewfarmery
    Participant

    ok great, well I loaded an earlier save, and its been fine so far, I think with that included save I did station bulletin jobs, but with my earlier save I not touched them, so not sure what be triggering that error, hopefully my save might be useful, or allow someone to track down what is causing this bug

    PS, question

    how do I use the fuel scope? not sure how to really do this, I try and fly to a gas giant, but Im either too low and crash, or too high and not pick up anything, I did manage to scoop some units of fuel up, but unable to repeat, so is there a trick to this?

    another question,

    station repairs and servicing, in frontier you were forced to visit stations to do a service for your ship, otherwise you get hyperspace miss jumps, now in pioneer I have jumped a lot, and wondering if this has been added yet? or will it? because I hope that if this does get added, you can do a huge amount of jumps before your ship requires a service, otherwise your forced to remain near populated areas (I know that the game isn’t that populated at the moment) but later it would still be cool to do a 100 or more jumps without miss jumping, as that did annoy me a bit in frontier, as it stopped you from really exploring

    but anyway, this is a great game, well worth playing, even if its not really ready yet, if I spot anything else wrong I will report it

    #83687
    Avatars2odan
    Participant
    Quote:
    I did manage to scoop some units of fuel up, but unable to repeat, so is there a trick to this?

    I don’t recall the specifics but its literally a matter of flying within the atmosphere and last time I checked it was pretty slow so you might have to enable time-acceleration. So just fall from orbit and kiss the atmosphere but don’t fall in 😉

    #83688
    Avatarmatthewfarmery
    Participant

    looks like I have to practice more, as everytime I now tried, I keep crashing into the planet or not going deep enough

    would be cool is there was a video that showed how to do this, as Im clearly missing something 🙁

    edit

    not sure if this helps or not, but these crashing trade ships error, and unexplained crashing to the desktop (which might be related) seems to occur near the end of the year, December time, I also got a save that is crashing when I hyperspace, or if I start the time, and the date is the 22 of Dec 3206

    edit 2

    I sped up time to get the time to January, then hyperspaced, and it was fine again, there is a issue somewhere concerning the end of the year, or hyperspacing to the new year, any other part of the year, seems fine, but problems do happen once the year is around the December time, or a little earlier, this could be another issue or part of the above, but clearly something isn’t right with the game’s clock,

    hope that helps, if you want me to add this to the bug tracker I can, I guess I will create an account, but anyway, hope someone figures out this issues, as apart from this odd and very annoying bug, the game has been very stable

    hope my info helps

    #83689
    Avatardurandal
    Participant

    For fuel scooping your ship speed must be higher that 2000m/s and density of atmo should be bigger that 1.

    #83690
    Avatarmatthewfarmery
    Participant

    well I am slightly getting better, I have to say its pretty hair raising getting that close to a gas giant, but with high detail, its quite a sight too 😎

    well I can manage it sort of, but I found having a system selected and using the jumpdrive to leave the planet rather then trying to escape it, as while at least it does give you an audible queue if you do scoop successfully, which is good, so it does work

    just going to have to practice a bit more, but yeah above 2000m/s seems to work, I originally was going a lot faster then that and was having major trouble, slowing the ship down to that speed does help a lot, even if escaping the planet isn’t easy (hence having a Plan B)

    so thanks for the tips, now at least I can scoop fuel to take a wander around the galaxy 😎

    and blamy there are some very big stars in this game, and some are pretty good to take a close look at,

    now I need to practice manual landings, something I haven’t quite got the hang of, but slowly getting there, (something I had massive trouble in frontier, so thank goodness its a bit easier in this game)

    but overall, this game is shaping up very nicely, now I wonder where to go next?

    #83691
    Avatardurandal
    Participant

    Fuel scooping is pretty trivial in set speed mode, you just need to make sure that you do not pick very big gas giant because gravity force of such mass is bigger than forward thrusters of many if not all ships.

    #83692
    Avatarmatthewfarmery
    Participant

    well it seems there is something up now whenever I do fuel scoop and hyperspace to another system

    if I hyperspace without fuel scooping, the game for the most part doesn’t crash, (no errors or anything just closes the game window) however if I do manage to fuel scoop some fuel then hyperspace it crashes (no errors)

    OK update, If I hyperspace to Epilson Eridani it does crash, but doesn’t if I select another system, yeah hyperspacing to other systems is fine so far, tried a couple, and no crash without an error, so whatever is trigging this crash is in Epilson Eridani, and might be linked to the trade ships bug, or might be something else?

    hope that helps someone, included a save if you need it

Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.