Home Forums Deep Space Salvage Yard Space Force: Rogue Universe Jumping to/from 'Sol <–> Ursa Major' makes me CTD

Viewing 7 posts - 1 through 7 (of 7 total)



A lot of scifi games are for sale on Humble Bundle, deals end on 8/19/2019


  • Author
    Posts
  • #60975
    Avatarfox
    Participant

    I’m playing Space Force: Rogue Universe.

    Patched to version 1.2

    I’m in free roam mode.

    I’d have no problems to report if it wasn’t for one that is occurring with a disturbing frequency: when I travel to/from Sol <–> Ursa Major the game is liable to CTD.

    Any idea what might be causing this?

    Though I’m not new to the game, the problem is new to me. I played SFRU 1-2 years ago and I used to jump from one system to the other all the time. I don’t recall any issue with any system.

    But then it was Win XP SP2, 32 bit, 4 GB ram, Dual Core CPU, with an old Zotac GeForce 9800 GTX (512 MB)

    Today it is Win 7 SP1, 64 bit, 16 GB ram, Quad Core CPU, and EVGA GeForce GTX 970 FTW ACX 2.0 (4 GB)

    In all honesty I don’t think my setup has anything to do with it. It may be instead because of the way I’ve been playing this time around. You see, I’m trying to Ally with all factions.

    I keep Pirates and UF enemy so I got something to shoot at, but otherwise all factions but the Collective consider me a friend. This is possible thanks to the missions that have you reactivate Satellites.

    Lately I was working on the Draglon faction and I got to Ursa Major to activate an array of Sats there, maybe get more quests while at it.

    I’ve been stuck in Ursa Major since.

    Help me.




    A lot of scifi games are for sale on Humble Bundle, deals end on 8/19/2019


    #106767
    sscadminsscadmin
    Keymaster

    Hmm, I don’t remember there being this issue when I last played a few years ago myself. Are you running the game in WinXP compatibility mode? Did you apply the right patch for your specific version (there is a USA and a UK patch for 1.2)?

     

    Have you also tried playing without the patch 1.2? The game itself hasn’t changed in years so I think its a OS issue or maybe your using an old save game or something.

    #106768
    Avatarfox
    Participant

    Hello,

     

    I tried everything except playing without the patch.

     

    Anyway, the crashes seem to have stopped. I don’t know why.

    When nothing would work I just settled and played a bit, killing time while thinking what to do. These crashes weren’t 100% sure to occur, but very likely to (like 85% chance).

     

    When I tried again the jump back to Solar system it didn’t crash. Maybe I got lucky?

    I jumped back to Ursa Major. Again no crash. I kept jumping back and forth. Not a crash since.

     

    No idea why it doesn’t crash anymore. The only change I can think of is that I picked up the piece of the Cloaking Device sitting in Ursa Major. But since I can’t load a save prior to that, I can’t make tests.

    #106769
    Avatarfox
    Participant

    I must have talked too soon. The crashes have returned. It just happens to be completely random. I can get past the problem by saving prior to attemting the jump. If I crash, reload and retry. But it’s annoying.

     

    So far it only happens when Ursa Major is involved — but I haven’t seen the whole map yet.

     

    From my experience when random crashes occur during specific events (such as game data loading/streaming) it is always down to the CPU, in a way or the other (might be the very game executable causing the crash, or it might be another module running in its address space).

    If this was an old game I’d say two or more threads are perhaps entering a ‘race condition’ (my CPU is a quad core) — but I have seen old games handle multi-core CPUs masterfully, as well as modern games fail epicly in the same regard.

     

    So I can’t be sure until I know more.

    I’ll fetch some tools and run tests on SFRU. If I come up with good results I’ll post here.

    #106770
    Avatarfox
    Participant

    I have results.

    Thread racing conditions *may* be not the cause of the crashes. I say this only because I have no proof of the opposite. While I couldn’t get the game to crash when constraint on a single CPU core, I couldn’t get it to crash when letting it loose on all cores either.

     

    The first crash I had, occurred much later in yet another play session. I believe the problem is within the dynamic nature of the star systems. Star systems in SFRU aren’t fixed, in that the number and placement of buildings can change based on the player’s actions. The stuff on sale (most notably the spaceships) can also change.

     

    A good example of this dynamism can be observed in Solar. Enter the uncharted gate near the center of the map. Get back to Solar from there. On your return a new EMD station sits at the center of the map, it sells only weapons and the EMD Valkyrie heavy fighter – otherwise impossible to buy in this system. Now get out of Solar via the charted gate, get back to Solar, and the new EMD station is gone and no Valkyrie is sold anywhere.

     

    Makkinists’ space is also prone to change in buildings number and position. The buildings that extract crafting materials and sell them to you at cheap price speak volumes of it. Things here tend to change based on which system you come in from, though I haven’t bothered to chart this data.

     

    Now, something along these lines is happening in Ursa Major, and at least one of the possible alternative system configurations is causing a CTD as you enter the system. Sometimes also when you leave (if it didn’t CTD on loading). But damn me if I get to understand when it occurs exactly.

     

    Having active quests also can modify a system configuration. In many a system hosting Chulta Olirion, Ezodar or Draglon space stations I saw on sale the Makkinist Fighter (possibly the best player ship in the game). But when I got back -without quests- to make the purchase, the Makkinist Fighter was nowhere on sale.

    #106771
    Avatarfox
    Participant

    guess it is no interesting topic — thanks anyway

    #106772
    PinbackPinback
    Keymaster

    Thanks for posting about it Fox, it maybe just that no one else has encountered the problem but it is always useful to have a record of any problems in case anyone else encounter it in the future.

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.