Home Forums Free SciFi Gaming Projects Pioneer Not Importing Ships, Definitely Not, No; Not Those Ones, Anyway

Viewing 8 reply threads



  • Author
    Posts
    • #61334
      Coldwind651
      Participant

      Let’s say I want to import some ships into my installation of Pioneer.

       

      Now, I want to be absolutely clear that I fully respect the Pioneer team’s decision to remove Frontier content[*]. And I would never consider trying to obtain the Frontier ships from anywhere else and crowbar them into my own copy of Pioneer in subversion of that decision[**], heavens forfend.

       

      So I have certainly NOT tried to pull the .json files out of a Scout Plus install and dump them into the Ships folder in Pioneer, assuming them to be much the same format; so clearly I have NOT then been confronted with a huge, red, rotating ERROR in place of each imported ship when I’ve run Pioneer. I imagine it’s the sort of thing that might happen if I’d been so misguided as to try such a thing.

       

      In view of all this not having happened, I’m obviously not here looking for any hints and tips someone might offer on why I might be seeing the said ERROR, or whether there’s a workaround for this.

       

      Hypothetically speaking, were I in the above-described position, I’d probably be quite grateful to anyone who could offer any advice, not that I’d deserve it, but, you know. But, you know, let’s say that I could use some advice on how to import ships in general. Perhaps the said general advice might cover this possible error?

       

      [* This bit is actually true.]

      [** This bit, not so much.]

      Fanatical - Official PC Game Keys

    • #108968
      impaktor
      Participant

      Haha. Funny guy!

      You know you’re perfectly allowed to blend and modify pioneer and scout+ any way you like. You are grabbing both the data/ship/-json files and matching data/models/ships/ files, right?

      I tried copying Cobra Mk1 A from Scout+ to Pioneer, and got some errors:


      LoadDDSFromFile: models/ships/cobramk1/skin_a.dds: could not read file
      LoadDDSFromFile: models/ships/cobramk1/spec.dds: could not read file
      LoadDDSFromFile: models/ships/cobramk1/glow.dds: could not read file
      LoadDDSFromFile: models/ships/cobramk1/pilot_skin.dds: could not read file
      LoadDDSFromFile: models/ships/cobramk1/pilot_spec.dds: could not read file
      LoadDDSFromFile: models/ships/cobramk1/pilot_glow.dds: could not read file

      But loaded like so:

      screenshot_20160115_105451.jpg

      I’m sure fluffyfreak or nozmajner can be of more help here.

    • #108969
      fluffyfreak
      Participant

      Interesting, not sure why Pioneer wouldn’t be able to read a DDS that Scout+ can since they should be the same copy if PicoDDS that I wrote.

       

      Might be a filename thing with DDS vs dds?

       

      Andy

    • #108970
      Kryos
      Participant

      Haha. Funny guy!

      You know you’re perfectly allowed to blend and modify pioneer and scout+ any way you like.

      That’s great. I was a bit worried it’d be considered a no-no, but thought this would be the best place to ask anyway. Thanks.

      You are grabbing both the data/ship/-json files and matching data/models/ships/ files, right?

      Well, how sheepish do I feel? 🙂

      Ahem. I might’ve forgotten to copy the actual model files… Those json files are kinda small, now I look at them…

      I might just go and try it again. Don’t mind me, everything’s perfectly under control here… :oP

      (Ack. Sorry about the name confusion. This was me trying to set Tapatalk up ages ago – looks like I’m still on two different accounts. –Actually Coldwind651)

      Sent from my GT-I9505 using Tapatalk

    • #108971
      impaktor
      Participant

      Pardon me being stupid. I actually put the ship model in data/models instead of data/models/ships, thus the error message. Putting it in the right place, and editing the json file to have a ship_class that is valid for pioneer fixed everything for cobra_mk1_a for me. Only thing missing is the ship manufacturer icon, which needs also be set from the json file, in the same way.

    • #111185
      Gernot66Gernot66
      Participant

      KmA

    • #111534
      Gernot66Gernot66
      Participant

      nice to see that some still like my “plagiatism” 😉

      like to get a couple of FFE ships?

      now i won’t convert them for the recent Pioneer, but i can hand you the models.

      Alternatively you can use the ones i released for FFED3D (if it’s still possible to use .X meshes), just keep in mind that the models of FFE are 10 times smaller as in pioneer.
      For some new ships you will have to refere to the models .ini because i used the original size and down or upscaling. this because in this way i can simply copy i.e. thruster positions from the original game content.

      Dunno how far you get but are textures now limited to the use of dds?
      i never liked it, it steals to much colors, more as a 256 palette will do and you have no way of influencing resp. using a dithering, it’s blatantly converted to somewhat less as 256 colors because some are reserved for the alpha channel (i assume 64). this is the “fabulous” compression of dds, stealing bytes from the texture.

    • #111548
      nozmajner
      Participant

      You can still use pngs for textures. We use dds to optimize memory usage.
      I was thinking about making a mod that replaces them with hi-res png-s, so one can choose to use them if their GPU is up to the job.

    • #111556
      Gernot66Gernot66
      Participant

      nozmajner, thanks for the prompt answer.

      It wasn’t really needed to answer to my thoughts, but well.
      but well, i said i won’t do it but if there is interest in FFE ships i will do it nonetheless i guess. (ment for impaktor or anyone who likes to get the FFE models in Pioneer, it’s for me no big deal to convert them. i guess i should start to forget the past and what went between us).
      dunno if i can run the recent release on my notebook, even if it’s a quite strong one it leaks of a GPU.
      Also i have a lot of differnent things in mind, respectively tasks i already atarted long ago, to fill FFED3D and work on “Phoenix* is hard enough for a single guy unconcetrated, easy to distract and interested even in old BASIC games.

Viewing 8 reply threads
  • You must be logged in to reply to this topic.