Home Forums Free SciFi Gaming Projects Oolite Oolite 1.84

Viewing 11 reply threads



  • Author
    Posts
    • #61519
      CodyCody
      Participant

      Oolite 1.84 hits the streets – change log here! A really solid, stable, release!

      Fanatical - Official PC Game Keys

    • #109763
      GeraldineGeraldine
      Participant

      Yaay! Multiple lasers! :girlcrazy:

      Oh…wait…the other NPC ships will have them too! Run away, run away! :girlimpossible:

    • #109764
      CodyCody
      Participant

      Runaway? Whatever you say, ma’am!

       

    • #109765
      pagroove
      Participant

      Yeah Oolite 1.84.. Still going strong 🙂

    • #109766
      XenonS
      Participant

      After a longer pause I’m comming back to Oolite and its interesting community OPZ/OPX packs and so I’ve downloaded the latest version (I believe this one, I don’t know though).

      I have big problems with my joystick Logitech WingMan 3D: immediately when I touch the stick the ship starts to move and spin around (yaw). I then set all Deadzone values for roll/pitch/yaw higher to 0.0850 but still the problem remains. What can I do in the settings? I really want to play with a joystick because keyboard / mouse will utterly give the AI any advantage in combat 🙂

       

      About OPZ/OPX packs:

      Is it enough to simply place them in the Addons folder to activate the packs?

       

      Thanks,

      XenonS

    • #109767
      CodyCody
      Participant

      Are you using Oolite’s joystick settings? Try adjusting the Axis Profiles using the Spline feature – that may help.

      Yes, OXPs and OXZs work fine from the AddOns folder – or you can use the in-game OXZ manager.

    • #109768
      XenonS
      Participant

      Hi Cody,

      I have checked that my joystick is recognized in my Windows 7, it is, and I re-calibrated it.

      Yes, I’m using the Oolite’s settings, I go in the Joystick Configuration and set the buttons/axes as I wish. I’ve already done as you suggest with the Spline making a smooth non-linear increasing curve, trying more or less severe Deadzone adjustments, but all this shows no changes to my problem: a little touch of the joystick and the ships starts spinning. If I make the stick vibrate a little bit with 2 fingers then the spin will eventually stop. But: using the joystick is currently impossible. The 2 Roll/Pitch bars in the HUD are correctly centered and don’t move during the un-volunteer spin.

       

      I will try to use another joystick, will have to grab in my numerous boxes…But my current joystick does well in other games that I’m currently in, like GP4 Formula One, or other flight sims.

       

      XenonS

    • #109769
      CodyCody
      Participant

      The 2 Roll/Pitch bars in the HUD are correctly centered and don’t move during the un-volunteer spin.

       

      <scratches head> That sounds like a problem with the joystick, but I’m not an expert on such things.

      Let me know how it goes with another joystick – you might have to ask the Oolite forum for advice.

    • #109770
      XenonS
      Participant

      Yep, thanks Cody, I’m already visiting the site and found an useful article about the joystick setup. I think I can get this to work.

       

      I have excavated a ‘Black Widow’ with manual throttle and stick combo. Will try that one.

       

      Ciao,

      XenonS

    • #109771
      CodyCody
      Participant

      Decent ‘stick, that. I use a Logitech Extreme 3D Pro – oodles of buttons!

    • #109772
      XenonS
      Participant

      Ok, it’s my joystick or the Yaw setting. I’ve just plugged a Wingmen Attack 2 with no 4th axis and no yaw (a predecessor of the WingMan 3D). Here no glitch whatsoever, all works fine. I now will re-plug the other one and disable yaw to see, but I doubt that’s it:

      The joystick is rather old and it didn’t get a gentle touch all over the time, if you see what I mean :mole:

       

      Problem solved,

      XenonS

    • #109773
      CodyCody
      Participant

      Cool! <grins> In the interests of equality, NPCs don’t use yaw – neither do I.

Viewing 11 reply threads
  • You must be logged in to reply to this topic.