Home Forums SSC Administration Troubleshooting my account from the switch-over

Viewing 15 posts - 1 through 15 (of 20 total)
  • Author
    Posts
  • #61581

    sscadmin
    Member

    Hi Everyone

    Didn’t think this was going to be this much of a pain in the ass but it ended up being one. So I am sorry about this.

    Basically here is the scoop;

    1. I export all of the users/posts/discussions/etc.. out of old IPBoard software and I use an importer to suck in all of this information with hopefully as little loss to data as possible. **– COMPLETE**
    2. I then connect Vanilla forums and WordPress together via a bridge plugin, I know they are not always the most reliable. But doing this for now because there is no good plugins for file download areas on Vanilla Forums. So this is what I am using for now until something better comes about. This plugin is active and is currently working, meaning I can login to both Vanilla Forums and WordPress using the same username and password. **–COMPLETE**
    3. Now for the users and this is the tough part:
    * In WordPress, register a new account with your existing SSC username and email address you registered with. When you set your password it will be beneficial for you to use the same password here. (I haven’t tried different ones to see if the link still happens)
    * Login to WordPress using that account info (same as SSC login info), this should be successful

    ![](http://spacesimcentral.com/forum/uploads/editor/m5/s1b4ni2rxa1l.jpg “”)

    – Now click on the ‘Forum’ link in the menu bar, page will load

    ![](http://spacesimcentral.com/forum/uploads/editor/id/et86apn9dj3s.jpg “”)

    – Now there should be an option to login via ‘Sign in with spacesimcentral’, click this. **Do not click either ‘sign-in’ or ‘register’ links**

    ![](http://spacesimcentral.com/forum/uploads/editor/ii/aa9kuybv0bv7.jpg “”)

    – You should be logged in now

    ![](http://spacesimcentral.com/forum/uploads/editor/c5/xwycypurzhbh.jpg “”)

    Simple huh 🙂

    -D1-

    #109975

    Cody
    Member

    Hey, D1 – after some fuss, I seem to be in.

    Is the migration being a PITA?

    #109976

    natansharp
    Member

    What a mess! Will the forum look like this?

    #109977

    Cody
    Member

    Still plenty of work to be done, methinks – takes time, and patience.

    #109978

    sscadmin
    Member

    Thanks. Yes it will take some time to theme everything up.

    Since I am running PHP7 for everything now. I will run into some conflicts with older themes and mods for WordPress and Vanilla Forums. So for now it might be ugly until more themes come out that support PHP7.

    The move to PHP7 is to future proof SSC a little, faster speed, better security and reliability. Also in this process the MySQL database was also updated to 5.6.x for better speed and reliability. Same with apache, it is running latest version as well.

    So there is a little pain. But I hope in the end it will be for the better.

    #109991

    natansharp
    Member

    Good work darkone…we are always ready for SSC spaceship!

    #109993

    Cody
    Member

    The front page and other pages look fine, but the forum page is only plain white with a simple list of categories. All rather strange. Is that how it should be?

    #109996

    sscadmin
    Member

    For now yes, trying to figure out how to best theme it. I will work on it all soon, trying to make stable and make sure there is no immediate website killing issues.

    One thing I noticed is how fast posting and stuff like that is. I haven’t seen any issues yet running PHP7 yet (crossing fingers).

    I will be working on this off/on this month (especially on Xmas break) so I hope I can read up on theming and try to make it a bit more custom if I can. I would use a forum theme, but hardly any are PHP7 compliant yet so this is default theme which works.

    #110000

    Cody
    Member

    Okay, cool – long as I know that’s how it should be.

    Looks like there’s a one hour time limit on post edits.

    #110001

    csmooth
    Member

    It didn’t see my old account, I was never that active on here; so anyway, I made a new account. I didn’t realize everything had been switched around. ITS BEEN A LONG TIME. When I made a new account I didn’t realize that we weren’t supposed to login on the main SpaceSim site, so I’m pretty sure that I’m an admin. Hi, new Admin XD. I’m a Linux Gamer, btw. I enjoy play STO on WINE. Just wanted to let the @sscadmin know.

    #110003

    sscadmin
    Member

    > Looks like there’s a one hour time limit on post edits.

    I can change this to whatever people want?

    > It didn’t see my old account, I was never that active on here; so anyway, I made a new account.

    That is no problem csmooth, do you happen to know your old username you originally registered with so I can pull it out? I don’t think your an admin but I will check 🙂

    #110015

    theAntiBob
    Member

    holy crap that was a pain! wordpress just shaking it’s ugly head back and forth, forcing me to do arithmatic… and questioning my spelling of arithmatic…
    i did eventually get to a point where it would just shake it’s head at me and NOT give me an error message…
    hope that’s all over now

    #110024

    sscadmin
    Member

    Haha sorry, its how I keep the bots out now. I know math is tough sometimes but us scifi types should be able to handle a little 🙂

    #110056

    shadmar
    Member

    I really liked the old forum better (no offense).
    It’s hard to navigate now. everything is white, no breadcrumbs.

    #110057

    argh, unable to reactivate my original account (NevilClavain) However i tried to follow the described procedure, but no ‘Sign in with spacesimcentral’ link at all

Viewing 15 posts - 1 through 15 (of 20 total)
  • You must be logged in to reply to this topic.