Forum Replies Created

Viewing 4 posts - 1 through 4 (of 4 total)



Humble Book Bundle ends on 9/11/2019


  • Author
    Posts
  • in reply to: !! Pioneer Question Time !! – Ask them here #74761
    AvatarRayvenQ
    Participant

    I’m just wondering how the illegal Goods mechanic works (if there is even one) as I always end up getting caught (Sure, i’ll probably get told “take it to where its not illegal” but theres no money in that.)




    Humble Book Bundle ends on 9/11/2019


    in reply to: Alpha 14 released #82856
    AvatarRayvenQ
    Participant

    Got this error when starting a new game with the new exe

    Quote:
    nError: data/modules/TradeShips.lua:39: couldn’t find constant with name ‘SHIELD’ in namespace ‘EquipSlot’

    stack traceback:

    [C]: in function ‘GetEquipCount’

    data/modules/TradeShips.lua:39: in function ‘addShipEquip’

    data/modules/TradeShips.lua:297: in function ‘spawnInitialShips’

    data/modules/TradeShips.lua:668: in function

    Error: data/modules/TradeShips.lua:39: couldn’t find constant with name ‘SHIELD’ in namespace ‘EquipSlot’

    stack traceback:

    [C]: in function ‘GetEquipCount’

    data/modules/TradeShips.lua:39: in function ‘addShipEquip’

    data/modules/TradeShips.lua:297: in function ‘spawnInitialShips’

    data/modules/TradeShips.lua:668: in function

    Gonna get the repackaged alpha 14 and try that and then see what happens.

    Tried it with the repackaged alpha 14 and got

    Quote:
    Error: data/modules/TradeShips.lua:39: couldn’t find constant with name ‘SHIELD’ in namespace ‘EquipSlot’

    stack traceback:

    [C]: in function ‘GetEquipCount’

    data/modules/TradeShips.lua:39: in function ‘addShipEquip’

    data/modules/TradeShips.lua:297: in function ‘spawnInitialShips’

    data/modules/TradeShips.lua:668: in function

    Error: data/modules/TradeShips.lua:39: couldn’t find constant with name ‘SHIELD’ in namespace ‘EquipSlot’

    stack traceback:

    [C]: in function ‘GetEq[/qu]te

    in reply to: Alpha 14 released #82852
    AvatarRayvenQ
    Participant
    durandal wrote:
    I cannot reproduce it on master, even if I enable sound and music, sfx is playing.

    Change DisableSound to 1 in config.ini and it should make game load, but you will get no sound/music/sfx…

    Did that, still getting this save contain errors.

    Tried making a brand new fresh save and then loading it immediately after (with DisableSound set to 1 before launching the game) came back with the same thing.

    Also got this in the STDerr file

    Quote:
    Game saved to ‘C:\Users\Username\Documents/Pioneer/savefiles//test’

    Savefile version 30. This saved game cannot be loaded because it contains errors.

    Could it be because of the flipped around and doubled slashes messing with the game?

    in reply to: Alpha 14 released #82847
    AvatarRayvenQ
    Participant

    Sadly, it seems pointless playing because if you save a game in A14 (and i noticed this in the previous nightly build) and then subsequently try to load it, it gives you the “this save contains errors” message.

Viewing 4 posts - 1 through 4 (of 4 total)