Notifications
Clear all

 


I use crypto.com app personally on a daily basis and its great and takes the stress out of learning crypto and the crypto debit cards are great, ask me anything on this. I will probably make a thread discussing crypto soon. REFERRAL CODE = p5mu64hcq4
 

Alpha 9 released

Page 1 / 10

robn
 robn
(@robn)
Captain Registered
Joined: 12 years ago
Posts: 1035
Topic starter  

We released Alpha 9 a few days ago. If you haven't got it already I highly recommend you check it out. Builds for Windows and Linux available here: http://pioneerspacesim.net/download

Changelog:

    New stuff
    Completely rewritten autopilot. Its now far more likely to get you where you're going without flying into things on the way.

    Rewritten combat AI.

    Rewritten mouse control.

    New combat target HUD with lead indicator and colour-coded closing rate.

    New planetary terrains.

    Identikit faces in starport screens.

    New HUD for radar mapper and hyperspace cloud analyser.

    Navigation computer to help you find your way around.

    Trade ships (ie large non-combat ships) spawned when you enter a system.

    Unexplored systems beyond about 500 light years from Sol.

Under the hood

    All ships checked and cleaned up for consistency and speed.

    Custom systems now defined in Lua scripts.

    Number of planet types reduced. Planets now have composition attributes that define atmosphere, ground metal content, water coverage, etc.

Little things

    Start ship is now sane.

    Ambient light when close to a planet to make the dark side visible.

    Mouse wheel support in scroll views.

    Press 'C' to return the sector view to the current system.

    Setting to enable/disable joystick support.

    Support for building with MSVC2010.

    Loads of bugfixes, optimisations and other bits.

Feel free to post your feedback, screenshots and everything else in this thread. Also drop in on the devs in #pioneer on irc.freenode.net.


Quote
ollobrain
(@ollobrain)
Lieutenant Registered
Joined: 12 years ago
Posts: 564
 

looking very good guys


ReplyQuote
OSH
 OSH
(@osh)
Master Chief Registered
Joined: 6 years ago
Posts: 116
 

Great! Time for testing!!!


ReplyQuote
Geraldine
(@geraldine)
Rear Admiral Registered
Joined: 6 years ago
Posts: 3423
 

Hit a little problem with Alpha 9, it quits when starting a new game with this error

"GL_ARB_point_sprite: Yes

glError: invalid operation caught at ..\..\src\WorldView.cpp:339

glError: invalid operation caught at ..\..\src\WorldView.cpp:339

glError: invalid operation caught at ..\..\src\WorldView.cpp:339"

Alpha 8 works just fine though.


ReplyQuote
robn
 robn
(@robn)
Captain Registered
Joined: 12 years ago
Posts: 1035
Topic starter  
Geraldine wrote:
Hit a little problem with Alpha 9, it quits when starting a new game with this error

"GL_ARB_point_sprite: Yes

glError: invalid operation caught at ..\..\src\WorldView.cpp:339

glError: invalid operation caught at ..\..\src\WorldView.cpp:339

glError: invalid operation caught at ..\..\src\WorldView.cpp:339"

Alpha 8 works just fine though.

Thats debugging output and is normal operation. The crash of course is not. A few people have reported this. I will follow it up with John when I next see him. There's not much I can do as I don't have a Windows system to test with.


ReplyQuote
robn
 robn
(@robn)
Captain Registered
Joined: 12 years ago
Posts: 1035
Topic starter  
robn wrote:
Geraldine wrote:
Hit a little problem with Alpha 9, it quits when starting a new game with this error

"GL_ARB_point_sprite: Yes

glError: invalid operation caught at ..\..\src\WorldView.cpp:339

glError: invalid operation caught at ..\..\src\WorldView.cpp:339

glError: invalid operation caught at ..\..\src\WorldView.cpp:339"

Alpha 8 works just fine though.

Thats debugging output and is normal operation. The crash of course is not. A few people have reported this. I will follow it up with John when I next see him. There's not much I can do as I don't have a Windows system to test with.

Just to make sure we've got all the facts, can you please list your OS version (including 32/64 bit) and graphics card.


ReplyQuote
Stardreamer
(@stardreamer)
Warrant Officer Registered
Joined: 13 years ago
Posts: 204
 

Hmm. A very crashy one, guys. As in 'not-playable for anything more than a minute'. Tried it from all three start positions and nothing lasts.

Windows 7 (64)

Radeon 5800

Catalyst 11.2


ReplyQuote
OSH
 OSH
(@osh)
Master Chief Registered
Joined: 6 years ago
Posts: 116
 
Code:
GL_ARB_point_sprite: No
Error: OpenGL extension ARB_vertex_buffer_object not supported. Pioneer can not run on your graphics card.
Error: OpenGL extension ARB_vertex_buffer_object not supported. Pioneer can not run on your graphics card.

Athlon64 2 GHz, Windows XP SP2 32-bit, Geforce 6100 (nForce 405)...


ReplyQuote
Geraldine
(@geraldine)
Rear Admiral Registered
Joined: 6 years ago
Posts: 3423
 
robn wrote:
Just to make sure we've got all the facts, can you please list your OS version (including 32/64 bit) and graphics card.

Sure thing robn, I am running it on XP service pack 3, 32 bit, with a GeForce 9500 GT. Vid drivers fully up to date (done yesterday just in case this was the cause) with a Pentium(R) D CPU 2.81 GHz and 2 gigs of ram. Also have Avast and Zone Alarm installed too, but I set both of these to gaming mode just in case. The crash happens seconds after showing the docking port wall when using any of the start positions. Also tried loading an Alpha 8 save game, but no luck there either.


ReplyQuote
Taquito
(@taquito)
Petty Officer Registered
Joined: 12 years ago
Posts: 49
 

Whoohoo! Testing! 😀


ReplyQuote
revetoty
(@revetoty)
Crewman Registered
Joined: 12 years ago
Posts: 1
 
Stardreamer wrote:
Hmm. A very crashy one, guys. As in 'not-playable for anything more than a minute'. Tried it from all three start positions and nothing lasts.

Windows 7 (64)

Radeon 5800

Catalyst 11.2

I have the same problem, the game crashes very often.

Running the game in Windows XP SP3 compatibility mode works well for me.


ReplyQuote
s2odan
(@s2odan)
Captain Registered
Joined: 14 years ago
Posts: 1212
 

And there I was thinking it was running so nice and stable on my win7x64 rig.


ReplyQuote
Geraldine
(@geraldine)
Rear Admiral Registered
Joined: 6 years ago
Posts: 3423
 
revetoty wrote:
Running the game in Windows XP SP3 compatibility mode works well for me.

Good one revetoty! Using compatibility mode set to Windows 2000 and turning off advanced text services helped a little. Now it just crashes a few moments after take off. I could try it on Vista and see if that helps.


ReplyQuote
Stardreamer
(@stardreamer)
Warrant Officer Registered
Joined: 13 years ago
Posts: 204
 

Ok, setting it to Win XP compatibility mode helped. The game has become playable. However, I don't think the shaders are working. I can't see any of the atmospheric effects or any of the shiny surfaces on ships. A step forwards, though. 🙂


ReplyQuote
s2odan
(@s2odan)
Captain Registered
Joined: 14 years ago
Posts: 1212
 

Theres a lot of changes with this release, so just bear with us and we'll surely get to the bottom of this.

Just to be sure, have you guys experiencing trouble tried changing settings in the options menu, like shaders off, shaders on ect... try with different planet quality too.


ReplyQuote
Floyd
(@floyd)
Crewman Registered
Joined: 12 years ago
Posts: 1
 

I'm experiencing the same issue, it crashes just after game starts (inside the station) i'm running on the minimum quality settings on XP SP3, 1.6ghz pentium, 1Gb ram, onboard intel 915 graphics chipset .it seems that this is a pretty universal problem with windows boxes. it is the same when runnning a savegame or from a starting point, it always crashes on the first go and usually runs fine on the second attempt.

Also, The starmap tends to occasionally go ape, occilating wildly and after a few seconds it ends up the other side of the galaxy! it then resets back to your original position.

Other than that i'm really impressed! I've started messing with custom systems, it would be really cool to create a little empire of my own! well done guys, great job!


ReplyQuote
shenle
(@shenle)
Senior Chief Registered
Joined: 12 years ago
Posts: 70
 

Here is what I do that crashes alpha9 each time.

Start at Epsilon Eridani.

Get launch permission, then don't touch keyboard and mouse anymore. You take off automatically, reach the top then start descending.

As soon as you touch the ground again, game crashes.

Tested with the same behavior on the following systems:

1. Win7x64/i7-2600/H67/8GB/geforce 9600GT

2. (laptop) Win7x64/Turion x2 TL-62/4GB/ATI HD3200

3. XP SP3 (32bit)/ Athlon64 X2-4400/2GB/geforce 8800GT


ReplyQuote
robn
 robn
(@robn)
Captain Registered
Joined: 12 years ago
Posts: 1035
Topic starter  

Thanks everyone for the reports and your patience. We will get this figured out.


ReplyQuote
s2odan
(@s2odan)
Captain Registered
Joined: 14 years ago
Posts: 1212
 

I take back what I said about it being stable, I hadn't actually tried the release version, only my own build of alpha9 which seems fine.

So here's a possible work-around, a re-build of alpha 9 that doesn't crash for me, give it a try and let me know how it works.

http://pioneerspacesim.net/sites/default/files/pioneer-ALPHA9%20RE-BUILD.7z

If it still crashes then there could be some problem with the data files, as thats the only possible difference between my working windows copy and the release version.


ReplyQuote
robn
 robn
(@robn)
Captain Registered
Joined: 12 years ago
Posts: 1035
Topic starter  

We think it was just a bad build the first time. We're preparing a 9.01 download and an updated exe which should be posted shortly.


ReplyQuote
robn
 robn
(@robn)
Captain Registered
Joined: 12 years ago
Posts: 1035
Topic starter  

Ok, go fetch: http://pioneerspacesim.net/download

There's a full package and a replacement executable. Hopefully this one goes better. Thanks again for the feedback, and now post pictures of pretty things 🙂


ReplyQuote
OSH
 OSH
(@osh)
Master Chief Registered
Joined: 6 years ago
Posts: 116
 

Same situation, old config deleted:

Code:
GL_ARB_point_sprite: No
Error: OpenGL extension ARB_vertex_buffer_object not supported. Pioneer can not run on your graphics card.
Error: OpenGL extension ARB_vertex_buffer_object not supported. Pioneer can not run on your graphics card.

Which cards are supported?? I have GeForce 6100 and alpha8 works without problems even with shaders!


ReplyQuote
Stardreamer
(@stardreamer)
Warrant Officer Registered
Joined: 13 years ago
Posts: 204
 

That's much better, guys, thank you. Game still crashes but it's always done that for me in every alpha so far. Am back to 'normal'. 🙂

Just taken her for a couple of quick test flights. The new navigation is brilliant - what a superb idea and implementation, although I'd still like hot buttons for every planet as well, not just Starports. On the other hand I can see why it's been made this way.

I'm still not completely sold on the HDR lighting. Distant stars look so much better without it, and it tends to make planetary surfaces a few shades too bright, garish in some cases.It does do some wonderful things for the atmospheric shaders, though, which is nice. But this is something that can be tweaked until perfect so I'm not going to complain too loudly just now. 😉

The new autopilot...wow, just wow. SOOO much better. Thank you! From start, If you leave from Earth and then select Mars High as your destination you are treated to a fabulous solar sunrise while the autopilot guides you around the Earth. Leaving Mars High headed for Io Base, however, it did crash me unceremoniously into Io, so perhaps there's still some tweaking to do here as well. Overall, though, this is a great improvement.

Will keep playing and reporting. Keep up the awesome work, guys!


ReplyQuote
robn
 robn
(@robn)
Captain Registered
Joined: 12 years ago
Posts: 1035
Topic starter  
OSH wrote:
Same situation, old config deleted:

Code:
GL_ARB_point_sprite: No
Error: OpenGL extension ARB_vertex_buffer_object not supported. Pioneer can not run on your graphics card.
Error: OpenGL extension ARB_vertex_buffer_object not supported. Pioneer can not run on your graphics card.

Which cards are supported?? I have GeForce 6100 and alpha8 works without problems even with shaders!

That particular test has been in the code since September 2010 so I'm not entirely sure what might have changed - maybe something in GLEW. I'll check with the more knowledgeable folk in #pioneer soon and let you know (unless someone chimes in here first).


ReplyQuote
ollobrain
(@ollobrain)
Lieutenant Registered
Joined: 12 years ago
Posts: 564
 

loading of all save games causes a crash but im guessing work arounds being worked on so il wait for a alpha 10


ReplyQuote
Page 1 / 10