Notifications
Clear all

 


I use crypto.com app personally on a daily basis and its great and takes the stress out of learning crypto and the crypto debit cards are great, ask me anything on this. I will probably make a thread discussing crypto soon. REFERRAL CODE = p5mu64hcq4
 

Sudden dramatic slowness and GL_OUT_OF_MEMORY


pirogronian
(@pirogronian)
Crewman Registered
Joined: 7 years ago
Posts: 9
Topic starter  

Hey, it's again me, unhappy with outdated but still working GeForce 8600M GT. I just installed last pioneer version (20161015-1). My software: Arch Linux, with legacy nVidia driver 340.98-2.

 

Game seemed to work fine, until sudden freeze (at spaceport, external view), then unfreeze, then freeze again, then unfreeze but being extremely slow (while leaving orbital spaceport), then became nornal again, and after some time became slow permanently (but only in 3d view screen, in other menus/views performance is normal). Twice I got widnow with warning about gl out of memory, the same was still in console:

 

In function DrawBufferIndexed

On line 769

OpenGL error(s) during frame:

GL_OUT_OF_MEMORY

 

 

I have no mods. Setting cleared and set from defaults. Added only "DisableEclipse=1", becasue it helped with previous issue.

 

Forget to add: all graphics setting set to minimum. Vsync both on and off.

 

I know my hardware is old, but I'm not so rich to buy something betetr and other programs (as FlightGear) worked fine, and I'm sad that the only usable space simulator is unplayable 🙁


Quote
fluffyfreak
(@fluffyfreak)
Captain Registered
Joined: 6 years ago
Posts: 1306
 

I am genuinely amazed that it runs on an 8600M!

 

Ok, lets try some other hidden settings that are there for coaxing it along on older machines.

 

So open up the `config.ini` then find these entries in it and change them to the following:

  • AMD_MESA_HACKS=1
  • EnableGPUJobs=0

Ignore the fact that it's called AMD_MESA_HACKS, that's just what it started out in life as and I don't want to break peoples settings by renaming it now 🙂

 

Try those first and let us know how it goes please.

 

Andy


ReplyQuote
fluffyfreak
(@fluffyfreak)
Captain Registered
Joined: 6 years ago
Posts: 1306
 

Oh and as usual if you can post the contents of the "opengl.txt" and "output.txt" files somewhere then that would be very useful thanks.


ReplyQuote
impaktor
(@impaktor)
Master Chief Registered
Joined: 6 years ago
Posts: 137
 

Another report on this through IRC, regarding the latest build, lastnight.


ReplyQuote
pirogronian
(@pirogronian)
Crewman Registered
Joined: 7 years ago
Posts: 9
Topic starter  

Well, after apply suggested changes in config.ini, problem seems to disappear, so probably I can mark it as "Solved". However, I'm linking opengl.txt and logs from working configuration, just in case:

BTW: Is output.txt a conventional name for console output? I have no such file in pioneer directory, so I pasted just console output.

 

I also noticed, that sometimes spaceport bulletin list is dramatically short (2 - 3 items), but is populated after fully game restart. If problem will continue, maybe I started new topic...


ReplyQuote
fluffyfreak
(@fluffyfreak)
Captain Registered
Joined: 6 years ago
Posts: 1306
 

There has recently been some progress on this with JohnJ finding a number of rendering issues which can cause performance problems, especially on AMD cards. When a new build is ready in the coming few days (_currently 27th, Nov,2016_) it might be worth trying that new build.


ReplyQuote
Shodan
(@shodan)
Petty Officer Registered
Joined: 6 years ago
Posts: 12
 

So i get this GL_OUT_OF_MEMORY error when visiting gas giants (Windows 7, Geforce 250GTS 1GB), on my usual detail settings (planet textures already disabled). Setting planet detail distance and fractal detail to very low allows me to orbit gas giants without error, but looking at the gas giant makes framerate very low and it looks all "grey" (jupiter), not sure if that's the normal appearance from orbital distances, with low detail.

I can't find a config.ini file, but there is a GasGiant.ini file in the data/config/ directory

Edit: actually it seems I get the GL_OUT_OF_MEMORY error even with the lowest detail settings, I think I didn't fully re-start pioneer the first time so the error was already present, giving the planet the "grey" appearance


ReplyQuote
fluffyfreak
(@fluffyfreak)
Captain Registered
Joined: 6 years ago
Posts: 1306
 

Shodan the config.ini / output.txt and opengl.txt files are to be found in your "/My Documents/Pioneer/" folder that we create when you run the game.

It the Gas Giant is grey then it sounds like a bug I've seen recently on my laptop where the GPU texture generation fails for an unknown reason - although I don't have the accompanying GL_OUT_OF_MEMORY error.

Find the config.ini and find the line saying "EnableGPUJobs=1", change that to "EnableGPUJobs=0" and try it again please.


ReplyQuote
fluffyfreak
(@fluffyfreak)
Captain Registered
Joined: 6 years ago
Posts: 1306
 

Shodan did you have any luck with this?


ReplyQuote
Shodan
(@shodan)
Petty Officer Registered
Joined: 6 years ago
Posts: 12
 

yep that worked, thanks


ReplyQuote