Notifications
Clear all

 


I use crypto.com app personally on a daily basis and its great and takes the stress out of learning crypto and the crypto debit cards are great, ask me anything on this. I will probably make a thread discussing crypto soon. REFERRAL CODE = p5mu64hcq4
 

[Sticky] SpaceSimCentral Maintenance Area

Page 3 / 11

DarkOne
(@sscadmin)
Supreme Dark Emperor Admin
Joined: 6 years ago
Posts: 7564
Topic starter  

Hmmm seems like the website is running well right now for me or least a lot faster. Maybe GoDaddy did adjust something and didn't tell me? Anyone else think the site is running better than the last few days?


ReplyQuote
Pinback
(@pinback)
99 Star General Moderator
Joined: 5 years ago
Posts: 8532
 

What ever you did, did the trick D1 as the site back to normal now. 😀


ReplyQuote
DarkOne
(@sscadmin)
Supreme Dark Emperor Admin
Joined: 6 years ago
Posts: 7564
Topic starter  

One thing I did do was remove the mchat mod from the forum page. People have complained in the phpbb forums that this mod sucks up some memory and database cycles since it is constantly being watched for updates and those posts are stored in the DB.

I will fully uninstall it tonight when I get home and see how everything is. And if that does seem to be the problem I will need to find another chat mod to play with.

Still bothers me that there seems to be issues with the site when I enable the php5 settings on the site.


ReplyQuote
LadynightShade
(@ladynightshade)
Master Chief Registered
Joined: 11 years ago
Posts: 115
 

how about making it into a blog page and let everbody post there ???


ReplyQuote
DarkOne
(@sscadmin)
Supreme Dark Emperor Admin
Joined: 6 years ago
Posts: 7564
Topic starter  
LadynightShade wrote:
how about making it into a blog page and let everbody post there ???

Did you have an idea on where you wanted this type of functionality to go? And is the intent to just have a random content area for people to post general comments or for an actual blog type functionality like a wordpress?


ReplyQuote
LadynightShade
(@ladynightshade)
Master Chief Registered
Joined: 11 years ago
Posts: 115
 

hmmm hard to say maybe next to forum and portal as a link , for now just keep working on the site darkone this host is giving me grief, painfully slow 😐 why did you have to move btw ? cost ? getting to big lol ??


ReplyQuote
shadmar
(@shadmar)
Warrant Officer Registered
Joined: 5 years ago
Posts: 301
 

Hi Darkone.

If you run ypur site off a linux server you should consider using varnish or nginx (reverse proxies) to offload all non session based traffic, this will free up allot of cpu-quota for pure php (logged in session browsing) since the reverse proxy will deliver cached from memory directly), and have almost no cpu usage.

I'm just guessing you're getting cpu bound by your provider, pure php via apache is parsed/interpered on every page displayed consuming alot of cpu, but can easily be speed up 10x times by cacheing non cookie/session based traffic.

Both are free to use, varnish is the easiest one to setup. Nginx take also do SSL, varnish cannot,

http://www.varnish-cache.org/

http://wiki.nginx.org/


ReplyQuote
DarkOne
(@sscadmin)
Supreme Dark Emperor Admin
Joined: 6 years ago
Posts: 7564
Topic starter  
LadynightShade wrote:
for now just keep working on the site darkone this host is giving me grief, painfully slow why did you have to move btw ? cost ? getting to big lol ??

It has been better the past two days least for me and a few others. Any better now for you? Why did I move... I moved the site because I reaching the threshold on database size and bandwidth. Now I have unlimited bandwidth and my DB size can be 1GB+ and my HD storage went up a bit. Was frustrating a bit yesterday when GoDaddy told me it was all me when I had the same code working on another host without issue. But we'll see what I can do the next few days.

shadmar wrote:
If you run ypur site off a linux server you should consider using varnish or nginx (reverse proxies) to offload all non session based traffic

I have a linux server but it is shared hosting. I will move to a dedicated server or least a virtual one once when SSC makes more $$. I can't install this type of software until I have a dedicated/virtual server.


ReplyQuote
DarkOne
(@sscadmin)
Supreme Dark Emperor Admin
Joined: 6 years ago
Posts: 7564
Topic starter  

Update on some of the things I have been working on.

This week I was going to start work on a fresh install of phpbb3.08 without the SEO mod because I think that is the reason why I am running into these problems. I will setup a fully running board and port my database over and see how it responds compared to the existing install. This is only tests and will have nothing to do with the current setup and it will be left alone. There is something going on and I want to find it!

I will let people know when it is ready so I can have a few folks login and test its speed and reliability.

Sorry for the delays in getting all of these issues resolved, I am working on it.

Update 3/29:

TO DO LIST:

- Create a ftp file area for people to upload files to help with rebuilding of the download database (Complete) - (Still need to work out some permission issues.

- Get wiki linked into main page (Complete) - Might unlock user registration this weekend

- Get gallery running on latest version (Complete)

- Create new videos page (old one wasn't cutting it) - (In Progress) - Just trying to figure out how to make youtube's video window bigger because adjusting the height/width values isn't doing it.

- Add country flag mod to site (Complete)

- Rebuild download area setup (Complete)

- Update links page to reflect wiki changes (Complete)

- Update about page to reflect changes to site (Complete)


ReplyQuote
Geraldine
(@geraldine)
Rear Admiral Registered
Joined: 5 years ago
Posts: 3382
 

Hi Darkone

An impressive amount of work done so far! 🙂

But I've got an awful amount of slow down navigating the site at the moment. It was going great there for a while too. Guess you are still busy behind the scenes?


ReplyQuote
DarkOne
(@sscadmin)
Supreme Dark Emperor Admin
Joined: 6 years ago
Posts: 7564
Topic starter  

I'm really puzzled as to why actually because code wise the sight should be performing better than it did at 1and1 since I removed some old code and tweaked some settings to help with calls to the db. All I can come up with is that there is something conflicting with GoDaddy and I just need to find out what.


ReplyQuote
Geraldine
(@geraldine)
Rear Admiral Registered
Joined: 5 years ago
Posts: 3382
 

Dont worry about it Darkone, I was trying to log in using the old way 😳 . Everything is fine now


ReplyQuote
DarkOne
(@sscadmin)
Supreme Dark Emperor Admin
Joined: 6 years ago
Posts: 7564
Topic starter  

Only reason why that wouldn't work Geraldine is because the site has changed a little that before the forums were at the root of the webserver (ie: /) and now they are at /forum. So now anyone that browses to spacesimcentral.com will get the WP page and you will need to click on the forum button or link directly to it. I am starting to work on the WP page functionality and converting my coded pages over to WP to give them all the same look and feel.


ReplyQuote
LadynightShade
(@ladynightshade)
Master Chief Registered
Joined: 11 years ago
Posts: 115
 

hellooo hellooo? can u hear me? oh right............. i guess its working again 😆

this is why i always back everthing up darkone alot of these so called host have no idea at what they are doing 😯

(im only typing here too see if everthing is working btw omg my avartar & sig are gone!!)

have to fix that later.... still using backup pc..... (edit fixed)


ReplyQuote
DarkOne
(@sscadmin)
Supreme Dark Emperor Admin
Joined: 6 years ago
Posts: 7564
Topic starter  

As you can see by my signature that was the value that was in the signature field in the database, so it doesn't work not sure why the db export did this? Doing a few more things and then I will backup the DB because I think the site is at a good state right now. I shouldn't be moving hosts for quite some time because this move was horrible. But it is done now and its just improving upon what I have new. Main things I will be doing this weekend is finishing up applying the mods and getting the file area back online (no files are lost), just the program switched directories and I probably have to adjust something. I will probably apply the original theme back to the forums to get rid of this blue look as well. 🙂


ReplyQuote
Pinback
(@pinback)
99 Star General Moderator
Joined: 5 years ago
Posts: 8532
 

The site seems to be suffering from a lot of spam bot over the last few days.


ReplyQuote
DarkOne
(@sscadmin)
Supreme Dark Emperor Admin
Joined: 6 years ago
Posts: 7564
Topic starter  

Tell me about it 🙂

I took off my multiple choice captcha and they came running in or maybe it was the installation of wordpress? Either way I will put the multiple choice captcha back on with scifi related questions and that should help. Its amazing really this one spammer made 137 posts in 6hrs. I am at the point now where if your username even looks like a spammer I delete it instantly. So for anyone that is a legit user sorry 🙂

I do have the download area online and it seems to be working well, thanks Geraldine again for the long hours uploading files and helping me test the download area yesterday. I have been slowly converting my pages to WP pages that need it. And noticed someone posted something about the link lists missing. They are in the wiki now. On the mainpage just hover over the wiki button and they will drop-down for you. I have yet to unlock registration just yet because I need to still do somethings in the wiki after I am done putting out the fires in the main site.

Gallery is totally done and working now as well. Its getting there and the site seems to be running well and that is the big plus.

I'm working on SSC all the chances I get, so if anyone sees anything broken or doesn't look right let me know.


ReplyQuote
Geraldine
(@geraldine)
Rear Admiral Registered
Joined: 5 years ago
Posts: 3382
 

Dont mention it Darkone, I was happy to help. I cant program and I am a rubbish modeller, so it was my way of helping the Space Sim Community 😉 Glad also you zapped that Spam bot. They are nothing less than a plague these days. Why do people create these stupid things? 🙄

And speaking of modelling, please have a think about your "Hammerhead" ship Pinback. It would look very spiffy in Pioneer, powered of course by the experimental 68000 hyperdrive 🙂


ReplyQuote
DarkOne
(@sscadmin)
Supreme Dark Emperor Admin
Joined: 6 years ago
Posts: 7564
Topic starter  
Geraldine wrote:
Glad also you zapped that Spam bot. They are nothing less than a plague these days. Why do people create these stupid things?

I guess they make money off people clicking on the links they make. But some good news on the battle against spam... I put my sortable captcha back in effect and I haven't had one spam bot register since 11pm last night (when I enabled the functionality). The questions are based on planets, star trek and star wars. They should be very easy to the scifi fan or takes a few secs to lookup of the answer on google 🙂

Sorry I have to be this way to any new users but I hate spammers with a passion and if anyone every has trouble joining you can email me and I will create your account manually.


ReplyQuote
Pinback
(@pinback)
99 Star General Moderator
Joined: 5 years ago
Posts: 8532
 
DarkOne wrote:
Its amazing really this one spammer made 137 posts in 6hrs.

I seen that spam bot working away yesterday morning when I looked in on the forum it was upto 78 post.

Geraldine wrote:

And speaking of modelling, please have a think about your "Hammerhead" ship Pinback. It would look very spiffy in Pioneer, powered of course by the experimental 68000 hyperdrive 🙂

Been thinking about having another go at Blender, got a couple of good book just need to find the time and the motivation to do some thing.


ReplyQuote
Brianetta
(@brianetta)
Commander Registered
Joined: 11 years ago
Posts: 863
 

Just thought I'd point out that the forum rules link in the pink bar near the top of the page is broken.


ReplyQuote
DarkOne
(@sscadmin)
Supreme Dark Emperor Admin
Joined: 6 years ago
Posts: 7564
Topic starter  
Brianetta wrote:
Just thought I'd point out that the forum rules link in the pink bar near the top of the page is broken.

Can't believe I forgot that file, I will take care of that this evening. Thanks Brianetta.

Was also going to try to get a links page and video page up and running. The links page won't be like before it will point to the different wiki pages I created for the different types of games (ie: SP/MP, MMO, Web and Mobile) and you can access this area from the mainpage. On the videos page I am still working on because I don't like some of the players and youtube's linked in player isn't all that great and lacks tweaking ability.

I will try to update the forum links (near the top) to put in a HOME button and possible wiki and gallery area. The last thing I will get to is any style customization because I have done a lot of work now to this prosilver template that I don't want to move from it 🙂 I might just adjust logos and change some image files around to get different results.


ReplyQuote
Geraldine
(@geraldine)
Rear Admiral Registered
Joined: 5 years ago
Posts: 3382
 
PINBACK wrote:
Been thinking about having another go at Blender, got a couple of good book just need to find the time and the motivation to do some thing.

Why not start small and mod the existing ship models? The Flowfairy (I always thought it was called Flower Fairy 🙄 ) and Sirius Interdictor could do with re-texturing and perhaps a few model tweaks? Anyways, sorry for being off topic Darkone 😳


ReplyQuote
DarkOne
(@sscadmin)
Supreme Dark Emperor Admin
Joined: 6 years ago
Posts: 7564
Topic starter  
Brianetta wrote:
Just thought I'd point out that the forum rules link in the pink bar near the top of the page is broken.

Should be fixed now.

Going to be working on the links page this evening. I'm getting there slowly, I make changes and observe the site for any bad activity. And seems that my changes slowed the spammer registration and posting efforts 😉


ReplyQuote
Braindead
(@braindead)
Master Chief Registered
Joined: 12 years ago
Posts: 108
 

Hey D1, I was wondering, does RSS still work? because the RSS you had previously is broken ATM.

the one I used was http://www.spacesimcentral.com/gymrss.php?digest

I've also tried http://www.spacesimcentral.com/forum/gymrss.php?digest but that doesn't work either... 🙁


ReplyQuote
Page 3 / 11