Notifications
Clear all

 


I use crypto.com app personally on a daily basis and its great and takes the stress out of learning crypto and the crypto debit cards are great, ask me anything on this. I will probably make a thread discussing crypto soon. REFERRAL CODE = p5mu64hcq4
 

Completed Pioneer Models

Page 20 / 25

Potsmoke66
(@potsmoke66)
Captain Registered
Joined: 6 years ago
Posts: 1815
 

was busy

[attachment=1221:Bildschirmfoto 2012-05-30 um 16.59.jpg]

[attachment=1220:Bildschirmfoto 2012-05-30 um 17.00.jpg]

(finished)

it's called MCU (maneuverable cargo unit, each unit has 60t cargo and 6 cabins, except 5 for the control unit) and can do nothing, except to carry cargo, available single, double and triple, thrust is just enough to maneuvre it (loaded 1.5g) has no hyperdrive therefore it needs...

"Caiman"

[attachment=1222:Bildschirmfoto 2012-05-30 um 15.04.jpg]

(unfinished, landing gear)

has a docking device to attach one or two caro units (separate models).

and i'm working on a "wheel station", but i won't present it until it's finished.


ReplyQuote
walterar
(@walterar)
Commander Registered
Joined: 6 years ago
Posts: 980
 

"was busy"

I thought you had changed Pioneer by hippie girlfriend. ๐Ÿ˜†

"it's called MCU ..."

Very, very interesting, a space train. Think missions. ๐Ÿ’ก


ReplyQuote
Skodyn
(@skodyn)
Senior Chief Registered
Joined: 11 years ago
Posts: 53
 
potsmoke66 wrote:

best is to patch the standard alpha22 set with this

Default Models

When I try to patch alpha22 with the above Default Models I get these errors, please help

Requested AA mode: 2x, actual: 1x

GL_INVALID_ENUM

Error: [string "./models/ships/cobra1/cobra1.lua"] call_model() to undefined model 'scanner_+'. Referenced model must be registered before calling model

stack traceback:

[C]: ?

[C]: in function 'call_model'

[string "./models/ships/cobra1/cobra1.lua"] in function

[C]: in function 'define_model'

[string "./models/ships/cobra1/cobra1.lua"] in main chunk

[C]: in function 'load_lua'

[string "pimodels.lua"] in main chunk

Error: [string "./models/ships/cobra1/cobra1.lua"] call_model() to undefined model 'scanner_+'. Referenced model must be registered before calling model

stack traceback:

[C]: ?

[C]: in function 'call_model'

[string "./models/ships/cobra1/cobra1.lua"] in function

[C]: in function 'define_model'

[string "./models/ships/cobra1/cobra1.lua"] in main chunk

[C]: in function 'load_lua'

[string "pimodels.lua"] in main chunk


ReplyQuote
Potsmoke66
(@potsmoke66)
Captain Registered
Joined: 6 years ago
Posts: 1815
 

that shouldn't be...

i checked it (again) and can see no problems, but i expect something wen't wrong ๐Ÿ˜‰

(i can see that already by the call for a "scanner_+", because it shouldn't exist anymore, i expect a "old" model in the "models/ships" dir.).

so i made a little clip to show how to patch the game and that it will run, it's simple, but a clip is better then thousend words.

unfortunately i run my MAC in german, but don't mind, "ersetzen" means "replace" and that's all you have to know.

besides of that, i know the procedure will be a little different for win or linux.

don't get confused by the different buildings, they are placed in "mods" and appear then in any pioneer you (i) will run.

if you miss any model after replacing the directories, just look out for them on the "single models" thread, i removed the cobra1 and the stardust from this set and none of my other models are included, only what's already in alpha22. thus, to leave it up to you to decide which you like in your game.


[/hr]

something different,

downloading from "skydrive" works for you?

that's good to know.


[/hr]

...to the MCU. i had the idea to use it mainly as a interplanetary vessel, useful to carry goods in a cheap way from a spacestation to another (or to a large transporter?), not particulary ment to land on or start from planets. unfortunately we have no (not yet) interplanetary taxi jobs, but i guess that shouldn't be a big problem.

i guess it's a nice boring way to start a career, doing only interplanetary runs with a basic space ship.

i guess it's in a state so i can upload it, it will need (sorry) the patched submodels, but there will be no getting around them for me in future ๐Ÿ˜‰ for many reasons.

edit: last minute change, i decided to place the mainpart to "sub_models", this will allow future use of the basic model as sub_model for anything.

[attachment=1226:Bildschirmfoto 2012-05-31 um 18.40.jpg]

mcu_12-05-31.zip

you won't have to wait long for the "caiman" ๐Ÿ˜‰

oh, i nearly forgot, meanwhile i worked on the "Viper X", removed the layers and changed the undercarriage resp. the "flaps" as well as i combined the textures.

and of course both models work only for a patched alpha22 and none of the nightly builds, this because of vital changes in the LMR (you can fix that yourself if you check the LUA files for all instances of "Matrix" and replace them with "matrix" that should do the job, further, as a hint for marcel, the docking sequence will change, i.e. "port_pos[port]:y()" changes to "port_pos[port].y", i can't say if this will stay in alpha23, but i assume it).

[attachment=1227:Bildschirmfoto 2012-05-31 um 21.41.jpg]

viper-x_12-05-31.zip


ReplyQuote
Marcel
(@marcel)
Captain Registered
Joined: 6 years ago
Posts: 1188
Topic starter  

Thanks for the hint, and the models. I'm still on dial-up so I can't check out alpha 23 stuff yet.

With my hometowns added there are already lots of in-system delivery jobs. That's all I've been doing the past couple of days because the game crashed during my trip back from Lave. I've gotten every add-on I can get in there so I didn't make a bug report. In preparation for alpha 23 I removed everyone's home town that didn't post to the Pioneer forum, which probably caused the problem. 26 spaceports destroyed, but it didn't make any difference in the frame rate around Europe. I may have to nuke it from orbit. Anyway, I made a delivery to Wattwil and found one of Philby's single pad stations there. I messed with the seeds until I found seed 25 to change it into one of your single pads instead. It just seemed like the right thing to do. I've been doing deliveries and if I land at one of the stations I've been working on, and it has a Og suit in the shipyard which I consider to be my work outfit, then I buy it and stay for a while and work on it. I just finished the basic_groundstation located at Croslee (hi Geraldine!). Removed 54 triangles. I can't stay too long because I have deliveries to make. I make a game of it this way. (that's probably a little bit weird even for you people) I'm thinking, once the deliveries are done, of trying to fly from Earth to Lave.


ReplyQuote
Potsmoke66
(@potsmoke66)
Captain Registered
Joined: 6 years ago
Posts: 1815
 
Quote:
I've been doing deliveries and if I land at one of the stations I've been working on, and it has a Og suit in the shipyard which I consider to be my work outfit, then I buy it and stay for a while and work on it.

๐Ÿ˜† good idea!

seems like i really should make a own one, i never was really satisfied by using a SW-XWA model, but i like the idea of a "Zerun".

i already started one, but delayed it due to lack of right imagination ๐Ÿ˜‰


ReplyQuote
Marcel
(@marcel)
Captain Registered
Joined: 6 years ago
Posts: 1188
Topic starter  

You know, I found the 0g to be actually useful for that sort of thing. When I was working on the pads I found that I could hover really close to them and see the details much more clearly than with the model viewer. It really helped me to get the window frames right. ๐Ÿ˜€


ReplyQuote
Potsmoke66
(@potsmoke66)
Captain Registered
Joined: 6 years ago
Posts: 1815
 

th_Bildschirmfoto2012-06-01um1454.jpg

th_Bildschirmfoto2012-06-01um1456.jpg

th_Bildschirmfoto2012-06-01um1458.jpg

th_Bildschirmfoto2012-06-01um1501.jpg

th_Bildschirmfoto2012-06-01um1502.jpg

caiman_mcu_12-06-01_b.zip

the Caiman comes together with the maneuverable cargo unit and i recommend to use this one, i changed some specs of the ship(s).

unfortunately the ships name changes a bit to, so if you have a saved game with the mcu (which i didn't expect) it won't run anymore.


ReplyQuote
Skodyn
(@skodyn)
Senior Chief Registered
Joined: 11 years ago
Posts: 53
 

Thanks Gernot, I did solve the problem by deleting Cobra1 but then when I added the Typhoon I started getting other errors. Not to worry I've left it for now and just started on the latest nightly.

I do like those new cargo units, I think they could be a lot of fun. It would be good if they could be pulled by another ship, but then just working out how you would load and unload them as separate units. Thinking it would be nice to have the option to have a fleet of ships and could change from one to the other at a station, then you could maybe unload the cargo you just transported from another system and jump into a fighter or a different cargo ship suited more to in system transport.


ReplyQuote
Potsmoke66
(@potsmoke66)
Captain Registered
Joined: 6 years ago
Posts: 1815
 

once upon a time, in a distant future ๐Ÿ˜‰


ReplyQuote
Potsmoke66
(@potsmoke66)
Captain Registered
Joined: 6 years ago
Posts: 1815
 

some evil force...

...is still ripping pieces out of earth ๐Ÿ˜‰

[attachment=1228:Bildschirmfoto 2012-06-02 um 11.49.jpg]


ReplyQuote
Marcel
(@marcel)
Captain Registered
Joined: 6 years ago
Posts: 1188
Topic starter  

Here's what I hope will be the final completed version of my upgrade to Philbywhizz's ground stations. This is for alpha 23. I'm hoping robn will be able to get it in there if it passes muster. If not, this can be added to your alpha 23 version of pioneer by dragging the enclosed data folder into your main Pioneer folder. It works with fae345c-win32. I won't enclose a picture because you can see it by scrolling up to potsmoke66's Viper X pic. Yeah, that thing. ๐Ÿ™‚

[attachment=1256:ground_stations_alpha23.zip]

Edit: Oh well, too late! ๐Ÿ˜†

I should also mention that I didn't put a backup ground_stations.lua file in there this time. If you don't back it up yourself you can extract it from your alpha 23 download if you want to change it back.


ReplyQuote
Potsmoke66
(@potsmoke66)
Captain Registered
Joined: 6 years ago
Posts: 1815
 

[attachment=1259:Bildschirmfoto 2012-06-09 um 03.jpg]

hmm...

[attachment=1260:Bildschirmfoto 2012-06-09 um 03.40.jpg]


ReplyQuote
Potsmoke66
(@potsmoke66)
Captain Registered
Joined: 6 years ago
Posts: 1815
 

ReplyQuote
Marcel
(@marcel)
Captain Registered
Joined: 6 years ago
Posts: 1188
Topic starter  

Yeah! I'm looking forward to flying those! ๐Ÿ˜€


ReplyQuote
Skodyn
(@skodyn)
Senior Chief Registered
Joined: 11 years ago
Posts: 53
 
Marcel wrote:
Yeah! I'm looking forward to flying those! ๐Ÿ˜€

Me too!! They do look great ๐Ÿ™‚


ReplyQuote
Potsmoke66
(@potsmoke66)
Captain Registered
Joined: 6 years ago
Posts: 1815
 

fixing the submodels for alpha23, added the new adverts textures, removed most dynamic stuff from them, scaled all down to 128x128px and used some of -0~0's ๐Ÿ˜‰ heads for the pilots now.


ReplyQuote
Potsmoke66
(@potsmoke66)
Captain Registered
Joined: 6 years ago
Posts: 1815
 

here we go,

the updated submodels for alpha23, this is ment to update the existing submodels directory, so it's possible to use them with the existing alpha23 standard models.

sub_models_and_functions_alpha23_2.zip

i hope it works it's not tested angainst all cases, but works as far as i can see with alpha23 and my ships together with the existing ones.

there are some changes to the adverts, but i kept some old names for compatibility, to make the new ones (spazeman) appear they have to be "plastered" somewhere.

and the two crazy ships from "X-Wing Alliance"

r41_and%20_supafighter_alpha23_1.zip

a bit outdated but nice,

i renamed the "Scout" to "Supafighter" which is the original name of the ship in "SW-XWA", i know sounds a bit silly...

don't get surprised by the weird front and rearview of the ships

both ships are ripped from "Star Wars - X-Wing Alliance", cockpit textures are taken from "YT-1300" and "X-Wing".


ReplyQuote
Marcel
(@marcel)
Captain Registered
Joined: 6 years ago
Posts: 1188
Topic starter  

Unfortunately, I have a bug report with your alpha 23 submodels. As soon as I press shift-3 for an outside view I get a red screen of death. The strange thing is, there's no text in it and according to task manager the game is still running. The music continues to play. One time I was at the starting position at the pad and saw one of your new scanners working fine on a Boa. This was in the front view, but again, going to outside view resulted in a red screen.


ReplyQuote
Potsmoke66
(@potsmoke66)
Captain Registered
Joined: 6 years ago
Posts: 1815
 

thanks, strangewisely i didn't checked the eagle and bought immediatly one of the new ships or any else "naked" from the shipyard.

so i knew it would have been with a big probability the scanner of the eagle fitted when you start, i know i had to re-use the old names, but forgot one version, sorry.

(my mac quits with a "black screen of singularity" ๐Ÿ˜† )

sub_models_and_functions_alpha23_3.zip

some standard models will have the scanner in wrong scale or position, sorry.

this will be fixed with the updated ships, there is no getting around that, because i changed a lot more neither only this for most of them.

ergo, my updated ships wont use them anymore, these are "scanner_+" and "scanner_-", i replaced them with "scanner" or one of the other scanner models.

btw, model "scanner" fits a "modern" scanner to the ships, use "big_scanner" for a typical saucer style scanner (which i used in my updated ships for the FE2 ships), "var_scanner" is the giant companion of "big_scanner" (i know the names are a bit confusing, but "var_scanner" means "various"), it's ment to use as scanner on buildings, etc,. it's scaled 25 : 1 compared to the "big scanner". "old_scanner" calls a steampunked grill type antenna.

with exception of the "var_scanner" are all models already scaled to รƒยขรขโ€šยฌรขโ‚ฌล“1, it might be they are a little to big for fighters, though a scale of 0.6 - 0.8 fits best for most scanner models if the ship is scaled 1:1.

they rotate now all in clockwise direction, if you need CCW then you have to build it from the submodels the scanners are made from (that was "scanner_-" was made for once).

also i fixed a little problem with the gender selection whtch has produced the wrong results and a male pilot wasn't possible to set (gender = 0) in the "selector.lua" script. don't forget you can (have to) still set a gender or a flightgroup color in "data/models/selector.lua". it's not 100% compliant to the old function and the standard models will work, but it will result in static selections for the texture and/or color variations of some ships.


[/hr]

[attachment=1269:Bildschirmfoto 2012-06-14 um 02.41.jpg]

the adverts textures are very low-res now, 128x128 for all of them, perhaps i upload a "original" (not really original but 256x256 was most old and is fine even for the new ones) scaled set.

for the creators of advert textures (spazeman) i use a standard size of 2:1 for all of them, thus to make them exchangeable where ever you like to place one.

and marcel, if you use textures by a path to another model, make sure they exist in the standard release, i guess "gravel.png" won't appear (produces the "noise" on the screen), anyway i geuss it's safer to use them exclusively (use the actual models directory or create a specific folder for all your models).

i guess i make a animated "noise screen" for you, so it will look like a real nois, perhaps interrupted by a test screen


ReplyQuote
Marcel
(@marcel)
Captain Registered
Joined: 6 years ago
Posts: 1188
Topic starter  

If you mean 'grav.png', that should be cloned into the stations/textures folder and called from there. If you see a place where it isn't, please let me know. It's not supposed to simulate static on the screen. I put it there to make a subtle mottled effect on the body of the big TV. The 'screen' is supposed to be the advert itself. I've been meaning to make the TV into a submodel inside spacestations.lua for quite some time now. Maybe I'll do that later today. I'm thinking of putting the 'ACME' in silver lettering at the bottom like my personal TV has 'SONY'. Putting the adverts on a TV screen is a subtle joke. Notice the green led? ๐Ÿ˜‰ As for the 'noise' advert and test screen, I think that's a really cool idea. Something else that would be cool is a randomize advert function. The ads could be placed at random in all their locations and would change at certain intervals. Perhaps once a day or every five minutes, something like that. Thanks for updating the submodels. I'll give them a test and report back. ๐Ÿ˜€


ReplyQuote
walterar
(@walterar)
Commander Registered
Joined: 6 years ago
Posts: 980
 

"Something else that would be cool is a randomize advert function."

Something like that?

๐Ÿ™‚


ReplyQuote
Marcel
(@marcel)
Captain Registered
Joined: 6 years ago
Posts: 1188
Topic starter  

EXACTLY like that! ๐Ÿ˜€ Except the ads are changing too quickly in my opinion. ๐Ÿ˜Ž


ReplyQuote
walterar
(@walterar)
Commander Registered
Joined: 6 years ago
Posts: 980
 

"Except the ads are changing too quickly in my opinion."

It is configurable. You can find spacestations.lua and station_splash.lua in https://github.com/walterar/pioneer/tre ... ata/models

It is very simple and can be improved.

If you can not download it from github let me know and we see otherwise.


ReplyQuote
Marcel
(@marcel)
Captain Registered
Joined: 6 years ago
Posts: 1188
Topic starter  

Walterar, I see what you did there. I like it! I'm thinking that we should have a general function like that to be called whenever someone wants to place an ad someplace. Call_ad(location) or something like that.

Potsmoke66, The new submodels work, except that ad_pioneer_0 shows the unknown.png texture because in adverts_p66.lua pioneer_0_l.png and pioneer_glow.png are called pioneer_0.png and pioneer_0_glow.png. I fixed it in my copy.


ReplyQuote
Page 20 / 25